Installation prerequisites

In order to install the OPQ system, you must first do the following:

Obtain the sources

Either:

  1. Checkout the source from https://github.com/openpowerquality/opq
  2. Download a release package from https://github.com/openpowerquality/opq

Install make

Most components require make, version ??. You can find it here.

Install other development tools

Install MongoDB

The OPQ system requires version 3.4 of MongoDB for cloud based data storage and retrieval. It's recommended that you install MongoDB using your system's package manager if its available. Otherwise, MongoDB can be obtained here.

Satisfy OS and hardware prerequisites

The OPQ system installs on modern Linux based systems and has been tested on Debian 8. Selected OPQ components such as Mauka and View can also be ran and tested on Macintosh based systems.

results matching ""

    No results matching ""